Flysky receiver problems

Talk about radio's, servo's, lighting, and anything else run though a reciever or radio here.
Post Reply
User avatar
vwjuice
Approved Member
Posts: 5613
Joined: Thu Jan 01, 2009 4:13 am
Location: Oregon city, Oregon

Flysky receiver problems

Post by vwjuice » Tue Jan 08, 2013 1:44 am

I have three Flysky receivers that have been sitting on the shelf and I went to use them today and all three of them have failed. Channel 1 is not working on all three and I tested two different tranmitters to see if it was a faulty transmitter. Has anyone else had any issues with this?
SFC K is my hero!
All bow down before the great terminator-smilie!

User avatar
vwjuice
Approved Member
Posts: 5613
Joined: Thu Jan 01, 2009 4:13 am
Location: Oregon city, Oregon

Re: Flysky receiver problems

Post by vwjuice » Thu Jan 10, 2013 3:28 am

Figured out the problem with my radio. The dual rate knob hassle a wire that somehow tore almost in half on both radios. I snipped the wire and cut it clean then resolve red it on and problem is fixed. Both radios now work just like they should.
SFC K is my hero!
All bow down before the great terminator-smilie!

User avatar
vwjuice
Approved Member
Posts: 5613
Joined: Thu Jan 01, 2009 4:13 am
Location: Oregon city, Oregon

Re: Flysky receiver problems

Post by vwjuice » Thu Jan 10, 2013 3:33 am

Figured out the problem with my radio. The dual rate knob has a wire that somehow tore almost in half on both radios. I snipped the wire and cut it clean then resolder it on and problem is fixed. Both radios now work just like they should.
SFC K is my hero!
All bow down before the great terminator-smilie!

Post Reply
Users browsing this forum: No registered users and 2 guests