savage x 2 speed not shifting?

Although not considered a traditional monster truck, they still have monster coolness.
Want to see your truck featured on the home page? Enter our monthly contest in the general discussion section!
Forum rules
Want to see your truck featured on the home page? Enter our monthly contest in the general discussion section!
Post Reply
megafan88
Approved Member
Posts: 54
Joined: Wed May 31, 2006 4:44 am

savage x 2 speed not shifting?

Post by megafan88 » Mon Jul 03, 2006 2:55 am

hey guys, i am new to nitro but i am learning quick. I have a savage x and it is on its 8th tank tommorow, and it is not shifting at all. The truck did shift on the 6th tank, but i was running it lean, but it ran perfect on the 6th. Although i did notice the engine winds out a lot before it shifts. I went to adjust it but could not find the adjustment screw in the tranny like it shows in the manual. I think it is hidden under the protecter and is not at the opening where it should be. Please, some help. :cry:
I dont really have too many rc's......do I? ;p

User avatar
132NHAF
Administrator
Posts: 2344
Joined: Wed Feb 18, 2004 1:40 am
Location: Southern California

Post by 132NHAF » Wed Jul 05, 2006 5:43 pm

I don't have a savage, but do have experience with the two-speeds. First off, 8 tanks is still not broken in. This is an important point since the truck is not making max power yet. I'm not sure where the adjustment is for that two-speed, but once you find the set screw, try opening it about 1/8 turn and see if that helps. Also realize that outside temps and of course running rich will affect how it shifts.

My suggestion is to take your time and make sure it's broken in well, then buy a temp gun (if you don't already have one) to make sure it's tuned right. After that, it should be shifting better, but if not, then you will know it's not the engine that needs adjusting and you can go from there.

Hope this helps.
Scott T

Stickers...Get your ClodTalk stickers here: viewtopic.php?f=2&t=25953

It's not WHAT toys you play with, but that you play with toys at all that is important.

User avatar
brushlesspede
Regular Member
Posts: 1156
Joined: Fri Aug 06, 2004 4:41 am
Location: South Louisiana

Re: savage x 2 speed not shifting?

Post by brushlesspede » Thu Jul 06, 2006 7:44 pm

megafan88 wrote: The truck did shift on the 6th tank, but i was running it lean, but it ran perfect on the 6th. :
How do you know it was running lean?
The democracy will cease to exist when you take away from those who are willing to work and give to those who would not.
Thomas Jefferson

megafan88
Approved Member
Posts: 54
Joined: Wed May 31, 2006 4:44 am

Post by megafan88 » Sun Jul 09, 2006 2:34 pm

I donnot know if it was running lean, i am guessing, probally not, anyways it is running great know, shifting right, blowing healthy blue smoke and running strong. No more worries! thanks for the help! 8)
I dont really have too many rc's......do I? ;p

buddy77
Approved Member
Posts: 27
Joined: Mon Jan 19, 2009 5:07 am

Re: savage x 2 speed not shifting?

Post by buddy77 » Mon Jan 19, 2009 4:25 pm

hey if run in alot of dirt make sure you keep the plugs in the trans to keep the dirt out . mine was clean and i had clutches sticking and it wouldent shift in to 2nd or 3rd . at time it would not even go in 1st

tri axle
Regular Member
Posts: 16
Joined: Sat Jul 04, 2009 10:58 pm

Re: savage x 2 speed not shifting?

Post by tri axle » Thu Jul 09, 2009 1:14 pm

I have a savage x 4.6 aswell and i put a three speed in. I also bought an axial 32 spec 1s to get the rpm up enough to shift into third gear. It is also that the motor rpm is not coming up enough.
It also could the adjustment on the transmission is off.

megafan88
Approved Member
Posts: 54
Joined: Wed May 31, 2006 4:44 am

Post by megafan88 » Sun Jul 12, 2009 2:14 am

Thanks guys lol this was 3 years ago lol. It runs great now! :lol:
I dont really have too many rc's......do I? ;p

Post Reply
Users browsing this forum: Google [Bot] and 3 guests